Degraded performance in mScales

Incident Report for mScales

Postmortem

mScales was temporarily unavailable due to a manual error related to a service certificate update. The certificate configuration was corrected, and the service was restored.

We are improving our processes around manual certificate updates to reduce the risk of similar issues in the future.

We apologize for the inconvenience and thank you for your understanding.

Posted Jan 08, 2026 - 09:47 EET

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 09:47 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2026 - 07:33 EET

Identified

mScales is currently unavailable.

Problem has been identified and we are working to fix this as soon as possible.

We apologize for any inconvenience this may cause.
Posted Jan 08, 2026 - 07:28 EET